Report inadequate content

Mac, Php in Harecoded

Expand

Instalar Memcache en Mac

Instalar el demonio de memcached en Mac no es tan complicado como parece siguiendo estos sencillos pasos.

Primero de todo asegúrate que tienes todos los requisitos

Requisitos para instalar Memcached

  • Un compilador GCC. No te asustes! Viene instalando las XTools de Mac si es que ya no las tienes
  • Descargarte el script de instalación desde topfunky

Instalación del servidor Memcached

Abre una terminal i navega hasta la ruta donde te has descargado el script. Dale permisos de ejecución y ejecútalo. Así:

chmod +x install-memcached.sh
sudo ./install-memcached.sh
echo "export EVENT_NOKQUEUE=1" >> ~/.bash_profile 

La última linea añade al inicio de tu shell la variable de entorno que requiere Memcache. Si durante la compilación ves que algo falla es que el compilador no está bien instalado. Asegúrate de bajarlo e instalarlo correctamente.

Si has instalado correctamente el servidor podrás ver la licencia o el manual de ayuda

memcached -i
memcached -h

Ahora, para arrancar memcached en mac con 100MB de memoria en el puerto 11211 como demonio haz:

memcached -m 100 -p 11211 -d

Puedes conectarte ahora y ver si está funcionando:

telnet 127.0.0.1 11211
	Trying 127.0.0.1...
	Connected to artomb.local.
	Escape character is '^]'.
	stats
	STAT pid 97257
	STAT uptime 10
	STAT time 1266004819
	STAT version 1.1.12
	STAT rusage_user 0.004421
	STAT rusage_system 0.005540
	STAT curr_items 0
	STAT total_items 0
	STAT bytes 0
	STAT curr_connections 1
	STAT total_connections 2
	STAT connection_structures 2
	STAT cmd_get 0
	STAT cmd_set 0
	STAT get_hits 0
	STAT get_misses 0
	STAT bytes_read 7
	STAT bytes_written 0
	STAT limit_maxbytes 104857600
	END
	quit
Connection closed by foreign host.

Para pararlo, tampoco sin misterios, un kill y arreando:

killall memcached

Instalar Memcache para PHP en Mac y scripts MAMP

Si quieres además integrar todo esto en MAMP para que se inicie al arrancar y instalar las librerías PHP hay un tutorial inglés muy bueno en Lullabot

Expand

Textmate: Plugins de PHP, Smarty y Subversion

TextmateTextmate es sin duda uno de aquellos editores para Mac OS X de los que hacen quitarse el sombrero. Como muchos otros editores, Textmate también soporta plugins (Bundles les llaman) y se pueden instalar un montón de ellos.

Para los programadores y webmasters que trabajan con PHP hay dos Bundles de especial utilidad: los que permiten Autocompletion para Smarty y Autocompletion para PHP. Para instalarlos simplemente hay que ejectuar en una terminal:

mkdir -p /Library/Application\ Support/TextMate/Bundles
cd /Library/Application\ Support/TextMate/Bundles
svn co http://macromates.com/svn/Bundles/trunk/Bundles/PHP.tmbundle
svn co http://macromates.com/svn/Bundles/trunk/Bundles/PHP\ Smarty.tmbundle

Si tenías Textmate abierto, pues simplemente hay que ir al menú Bundles -> Bundle Editor -> Reload Bundles

Plugin SVNMate TextmateUtilices PHP o no, no hay persona humana que pueda dedicar su tiempo a la programación un mínimo de tiempo y no utilize un sistema de versionado de código. Si eres de los amigos de SVN, recomiendo instalar el plugin SVNMate para ver en el drawer los iconos del estado de los ficheros. Algo que nos permite rápidamente ver el estado de nuestro proyecto :)

SVN diff TextmateInstales o no este plugin, Textmate ya lleva incorporado un cliente svn similar a TortoiseSVN, pero para Mac, claro. Para acceder al menú SVN simplemente utiliza la combinación de teclas:

CTRL+SHIFT+A

Para ver el listado de Bundles oficiales de Macromate, visita la URL:

http://macromates.com/svn/Bundles/trunk/Bundles/