Report inadequate content

Subversion (svn) 1.5 para Mac OS X

{
}

SCPluginSi utilizas distintos sistemas operativos y en ellos utilizas versiones distintas de subversion te habrás encontrado alguna vez con el mensaje de error:

svn: This client is too old to work with working copy '.'; please get a newer Subversion client

Si eres usuario de Mac y te ha pasado esto, o simplemente necesitas un cliente svn 1.5 para mac puedes descargarte la última versión de SCPlugin que ya incluye soporte para la 1.5, no es como TortoiseSVN, pero que le vamos a hacer :)

Con SCPlugin no vas cambiar la versión de command line, pero también puedes hacerlo utilizando el package de Martin Ott. Si utilizas algun sistema de ports en MacPorts puedes descargar también la versión de command line y si utilizas Fink, igualmente.

{
}
{
}

Comments Subversion (svn) 1.5 para Mac OS X

Ais... ¿cuándo alguien se va a currar un cliente GUI tan completo como TortoiseSVN pero para Mac? Ni Versions ni Cornerstone incorporan la posibilidad de hacer merges. :P
Estamos dejados de la mano de Dios.... ains!
Hola,
buscando buscando aquí he llegado :) habéis tenido alguien noticias frescas sobre este tema. Yo instale el SCPPlugin etc pero en Finder, cuando hago el checkout me crea la carpetita en verde, pero el Update.... infinito y no baja nada.
Gracias de antemano ;)
vatemu vatemu 31/03/2009 at 21:01
No se nada de este tema. Prueba a ver si puedes hacer un update manual via terminal. Quizá sea problema del repositorio...
ok, y cómo puedo hacer el update via terminal? Sorry, soy nueva con Mac y me da respeto el terminal ¬¬
vatemu vatemu 01/04/2009 at 22:38
Abres el terminal (Está en Aplicaciones/Utilidades)
Navegas hasta la carpeta donde has hecho el checkout con el comando "cd"
Por ejemplo:
cd miproyecto/
Luego escribes esto y le das al enter:
svn update
Si te dice command not found es que no tienes subversion instalado. Si te dice "is not a working copy" y estás en la carpeta que has hecho checkout, entonces el checkout no te ha funcionado.
Otros comandos útiles son:
svn info
svn status
he probado lo que dices y me sigue dando el mismo error la versión se supone que es la más nueva, cuando le doy a upgrade, me dice que no hay nada más nuevo, sinembargo, sigue diciendome lo de "too old.." que hago????
gracias!! :)
fifamfofam fifamfofam 26/02/2010 at 03:24
Muchachos este artículo es del 2008!!!!
En este momento la última versión es la 1.6 y el SCPlugin creo que ya no está soportado.
En este mismo blog podréis encontrar diversos artículos de subversion y mac, dadle a los tags.

Leave your comment Subversion (svn) 1.5 para Mac OS X

Log in to Obolog, or create your free blog if you are not registered yet.

User avatar Your name